Skip to content

System Requirements

Neuron ESB installations can be categorized as either server installations or client installations. A server installation is a full installation of the Neuron ESB, while a client installation communicates with a remote Neuron server via the Client API.

Server Installation

For use in a production environment:

Component Recommended
Processor 2.2 GHz Pentium IV or Athlon or higher (minimum 2 cores)
Operating System Windows Server 2012 R2
Windows Server 2016
Windows Server 2019
RAM 16 GB on 64-bit Windows
Disk 1 GB of available space

Client Installation

For use as an entry level messaging solution, or for product evaluation:

Component Recommended
Processor 2.2 GHz Pentium IV or Athlon or higher (minimum 2 cores)
Operating System Windows Server 2012 R2
Windows Server 2016
Windows Server 2019
Windows 10
RAM 8 GB on 64-bit Windows
Disk 500 MB of available space

Prerequisites

In order to install and run Neuron ESB 3.5, 3.6, 3.7 or 3.7.5, the following software needs to be installed on your computer. The Neuron ESB installer will attempt to locate these software packages on your computer. If the software packages are not present, the Neuron ESB installer will attempt to download the software packages over the Internet and install them for you.

Neuron ESB 3.5 Prerequisites:

Neuron ESB 3.6 Prerequisites:

Neuron ESB 3.7 Prerequisites:

Neuron ESB 3.7.5 Prerequisites:

If your computer does not have Internet access, please use the hyperlinks below to download the software packages and install them on your computer prior to installing Neuron ESB.

The following optional software may also be required, depending on your solution needs.  See the descriptions below:

Microsoft .NET Framework 4.5.1

.NET Framework 4.5.1 is a prerequisite for all machines running Neuron ESB 3.5, including client machines using the Neuron API.  If Microsoft .NET Framework 4.5.1 is not installed, the Neuron installer will automatically install it for you.

 You can download .NET Framework 4.5.1, here.

Microsoft .NET Framework 4.7.1

.NET Framework 4.7.1 is a prerequisite for all machines running Neuron ESB 3.6, including client machines using the Neuron API.  If Microsoft .NET Framework 4.7.1 is not installed, the Neuron installer will automatically install it for you.

You can download .NET Framework 4.7.1, here.

Microsoft .NET Framework 4.7.2

.NET Framework 4.7.2 is a prerequisite for all machines running Neuron ESB 3.7, including client machines using the Neuron API.  If Microsoft .NET Framework 4.7.2 is not installed, the Neuron installer will automatically install it for you.

You can download .NET Framework 4.7.2, here.

Microsoft .NET Framework 4.8

.NET Framework 4.8 is a prerequisite for all machines running Neuron ESB 3.7.5, including client machines using the Neuron API.  If Microsoft .NET Framework 4.8 is not installed, the Neuron installer will automatically install it for you.

You can download .NET Framework 4.8, here.

Windows Installer 4.5

Windows Installer 4.5 is a prerequisite for all machines that will execute the Neuron installer.

 You can download Windows Installer 4.5, here.

MSMQ

If you are using an MSMQ topic, you must install MSMQ on the server as well as all client machines.  

More information about installing MSMQ can be found here.

Microsoft SQL Server

To add a Neuron ESB Database to your Configuration, you will need to install Microsoft SQL Server.  The Microsoft SQL Server installation can either be on the local machine or on a remote server.  Your installation of Microsoft SQL Server must meet the requirements that the following table describes.

Versions SQL Server 2012 (all Service Packs)
SQL Server 2014
SQL Server 2016
SQL Server 2017
SQL Server 2019
SQL Azure
Editions Enterprise
Standard
Developer
Express
Workgroup
Compact
Installed Components SQL Server Database Services
SQL Browser Service
Collation Settings Must be accent sensitive

Must be case insensitive

Must not be binary

Must not be binary – code point

To avoid problems with double width or Hiragana/Katakana equivalent characters, select the appropriate check boxes to enable Kana and width sensitivity when you install SQL Server.
Authentication Windows Authentication or SQL server login depending on configured connection string.
Service Account All services are run with an appropriate domain account

Erlang/RabbitMQ

Neuron ESB supports Topics based on RabbitMQ Server. Installation of RabbitMQ Server is optional and is not required to use Neuron ESB 3.5.4, 3.6 or 3.7. However, if the Event Processor is installed with 3.7.5 it will require an installation of Rabbit MQ within the environment. If RabbitMQ Server is not installed, the Neuron ESB installer will give you the option of automatically downloading and installing Erlang and RabbitMQ Server. If you want to use RabbitMQ based Topics, but your computer does not have Internet access, please download and install the following software packages before installing Neuron ESB. Neuron ESB 3.5.4 has been upgraded to support Erlang version 18.1 and Rabbit MQ version 3.5.6, while Neuron ESB 3.6 has been upgraded to support Erlang version 20.2 and Rabbit MQ version 3.7.1. Neuron ESB 3.7 and 3.7.5 have been upgraded to support Erlang version 23 and Rabbit MQ version 3.8.5

Neuron ESB 3.5:

Neuron ESB 3.6:

Neuron ESB 3.7 and 3.7.5:

More Information

The latest information for installing Neuron ESB can be found in the README.html file that is included with the Installation Package of Neuron ESB. The README.html includes detailed information regarding dependencies, database upgrades, client API assemblies and redirects as well as security information.

Was this article helpful?
Dislike 0